Could not install the tool

May 22, 2012 at 7:52 PM

Hello there!

I have a SharePoint 2010 farm with a front and back end servers. We use AAM’s to access the site both internally and externally. We have an extended web application to help in Search. When I try to install or even expand the available webs in the site collection from this tool, I get a null reference exception. Nothing is getting logged in the event viewer. I ran the tool and used it successfully on my development machine, so I wasn’t sure if it’s the tool or my Test environment set up.

 

System.NullReferenceException: Object reference not set to an instance of an object.
at CodePlex.SharePointInstaller.InstallProcessControl.GetFeaturedSites(SPWebApplication webApp, IList`1 res, List`1 featureIds) in C:\Users\Administrator\Desktop\test\Source\InstallProcessControl.cs:line 344
at CodePlex.SharePointInstaller.InstallProcessControl.GetFeaturedSiteCollections() in C:\Users\Administrator\Desktop\test\Source\InstallProcessControl.cs:line 332
at CodePlex.SharePointInstaller.InstallProcessControl.Open(InstallOptions options) in C:\Users\Administrator\Desktop\test\Source\InstallProcessControl.cs:line 262
at CodePlex.SharePointInstaller.InstallerForm.ReplaceContentControl(Int32 index) in C:\Users\Administrator\Desktop\test\Source\InstallerForm.cs:line 183
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

 

Any help will be greatly appreciated. Thanks.

Coordinator
May 24, 2012 at 10:57 PM

Hello. Do you have the problem with installation of this tool or with using this tool. If you have problem with instalation(setup.exe) of this tool please install it directly from power shell and after that go to administration and there deploy it to any site collection you want. After you deploy it please go to site collections settings page and Activate this tool. Please let me know. Thank you